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1 Concepts 

COS PIM 
Compano Online Software, Product Information Management. 
 
Product 
A product is a manufactured and often branded object which can be described in technical terms. Usually, 

this product information is maintained by the manufacturer of the product. 
 
Item 
An item is a (collection of) product(s) which are packaged and priced. An item can also be described in 
logistical terms (stock, delivery time). Usually, this trade information is maintained by the supplier of the 
product. 
 
Assortment 
An assortment is a collection of purchase or sales items. 
 
GLN 
A Global Location Number (GLN) can be used by companies to identify their locations, giving them complete 
flexibility to identify any type or level of location required, for instance, a factory, store, office or warehouse. 
 
GTIN 
The Global Trade Item Number (GTIN) is an identifier for trade items, developed by GS1, www.gs1.org. Such 
identifiers are used to look up product information in a database (often by entering the number through a 
barcode scanner pointed at an actual product) which may belong to a retailer, manufacturer, collector, 
researcher, or other entity. The uniqueness and universality of the identifier is useful in establishing which 
product in one database corresponds to which product in another database, especially across organizational 
boundaries. 
 

Classification System 
A classification system identifies (technical) products, sorting them into product classes and describing them 
using standardized product features and feature values. Examples of classification systems are: ETIM, EZ-
base, GPC, Q-model, etc. 
 
ETIM 
ETIM is an international classification standard for technical products of the installation sector, the 
construction sector and the maritime sector. ETIM Dynamic is the current development version of ETIM, 
which is updated weekly. Previous, fixed version of ETIM include ETIM 7, ETIM 6, etc. 
 
BIM 
Building Information Modelling (BIM) is an intelligent 3D model-based process that gives architecture, 
engineering, and construction (AEC) professionals the insight and tools to more efficiently plan, design, 
construct, and manage buildings and infrastructure. 
 
ETIM MC 
ETIM Modelling Classes (ETIM MC) is an extension to the basic ETIM classification model, specifying 
parameters for representation of products as 3D geometric objects. As such, ETIM MC enables uniform 
exchange of 3D product data among users and CAD software. 
  

http://www.gs1.org/
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2 Introduction 

This document describes how to classify products within the COS PIM software using a standard 
classification system. For practical purposes, all examples demonstrate this classification process using ETIM 
Dynamic standard as the classification system1. 
 
Classification within the ETIM system is based on identifying an unique ETIM product class for each product. 
Once this class has been assigned to the product, the corresponding product class features can be filled in. 
 
Example 

• A product is assigned the class Convector radiator with EC-code EC010152. 

• Some of the corresponding class features are: Material housing, Material heat exchanger, Height, 
Length, Depth, Heat emission according to EN 442 20 °C - 75/65, Colour, etc. 

• For Material housing, the following values can be filled in: Steel, Plastic, Wood, Other. 

3 Classification process 

The best practice for classifying (new) products, is to work with a set of similar products. These products 
should all share the same product class and preferably many of the same class feature values. 
 
Example 
A good example of a set of products would be all radiators of the Series EcoLine, Type Convector Radiator 
Free-standing, which are all made of RVS (Material housing), and are all White (Color). These products 
then would only differ in their Dimensions (Height, Length, Depth). 
 

 

3.1.1 Classification of new products 

When classifying a new product: 
 

1. Find a set of products of a single class using Filter and Search, 
2. Assign a product class (ETIM) to all products in the set, 

3. Enter common values to class features which are the same for all products in the set, 
4. Enter unique values to class features which are different for each product in the set, 
5. Set classification status to classified . 

 
Note: Using the ExcelForImport method, steps 3 and 4 can be done simultaneously. 

3.1.2 Updating classification 

When updating existing classification, products already have a class assigned and part of the class features 
might be filled out. 
 
Note: This method is preferred for quick updates of classification data for new products. To this end, the ETIM 
class should be imported along with the standard product data: 

 
1 Should you wish to use another classification system, simply substitute ETIM for the system of your choice. Note that 
you will need to contact Compano Sales (sales@compano.com) as using other classification systems is not a standard 
feature of the Compano (Basic) PIM system. 
 

mailto:sales@compano.com
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To update classification: 

1. Find a set of products of a single or multiple classes2, using Filter and Search, 
2. Update classification data by entering values for class features which are missing data, 

3. Set classification status . 

3.2 Deleted ETIM features 

As ETIM Dynamic receives a weekly update, the ETIM classification system may change. This means that 
sometimes ETIM class features or values are deleted. 
 
By default, deleted ETIM features will still show when classifying products with the Compano software. This 
can lead to the confusing situation where a product feature shows twice, or where an already deleted feature 
is filled out instead of the correct active feature. 
 
In the COS interface, deleted ETIM features are marked with an Archive icon: 

 
In Excel exports, deleted features added as data columns after the active ETIM features. Also, any filled out 
values for deleted features are shown on a red background: 

 
2 Note: As of Compano Software version L03, it is possible to update the classification of products of multiple, different 

classes in one update session. For a detailed explanation, see chapter 8. UPDATE CLASSIFICATION. 
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3.2.1 Hide deleted ETIM features 

Deleted ETIM features can be hidden in the user interface. This setting is available under My details > My 
settings, however as additional action is required which is not available to a user, please contact your 
Compano consultant if you need to hide deleted ETIM features. 

4 Find a set of products 

The Filter and Search options in COS allow for a quick selection of a set of (similar) products. COS offers two 
kinds of filter techniques: a Quick Filter and a Comprehensive Filter. Note that both filters can be combined 
and that results can be further narrowed down by using an additional Search term. 

4.1 Quick filter 

The Quick Filter is available in the upper right corner of the right side panel: 
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The Quick Filter allows for a fast selection of products based on Manufacturer, Brand, Series, Type, 
Assortment, etc. The ; depending on your selection, it will only list filter 
options that can be further applied to your data. 

4.2 Comprehensive filter 

The Comprehensive Filter can be used to make a more refined selection of products for classification. The 
Filter offers several tabs with data fields which can be used in combination to filter out a set of products. 
 
Note: Complex filters can be saved for easy future use. For more information on Filtering, see the Compano 
Basic Manual. 
 
Example 
To filter a set of similar, new products: 
 

1. Through the Menu go to Products > Product Classifications: 

 
2. On the View tab, click the Filter button 
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3. In the pop-up window, enter the filter criteria on either of the following Filter tabs: 

a. Classification tab: Set Product Class to Empty to filter out all new products which do not 
yet have class assigned: 

 
b. Product tab: Optionally set additional Filter criteria to further narrow down the set of 

filtered products. For instance, Series, Type, Product Group, or a range of Product Codes: 
 

 
c. Additional tab: This tab contains additional Filter options, which can also be used to refine 

the filter results. Most practical would be such options as Time Created or Modification 
Time: to quickly find newly added or changed products: 
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d. User-defined fields tab (optional): This tab is only available with the User defined fields 

module (sold separately). When available use the options on this tab to filter on user 
defined fields values. 

e. Translations tab (optional): This tab is only available with the Multi-language module (sold 
separately). When available use the options on this tab to filter on translation values. 

4.3 Search 

Another way to find a set of product or narrow down your filter result, is to use additional Search terms. Enter 
one or more search terms into the Search box, for instance text from the description of the product, or part of 
a product code: 

 
Note: Search will try to match the search term with data in any data field. Depending on your search term 
this might result in a very specific result or too many results. 
 
Example 

 could result in the following matching products: 
 

• Ball valve 

• Ball valve handle 

• Ball valve sealing ring 

• Etc. 

5 Assign a product class (new product) 

New products must first be assigned the correct product class. 
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While there are other classification systems, this manual will take the ETIM Dynamic classification 
system as its point of departure. For the most part he instructions in this manual can also be 
followed when using a different classification system. 

To assign a product class, either: 
 

• Add the product class on import 

• Assign the product in PIM COS 
 

Please also see chapter 15. APPENDIX A: HOW TO FIND THE CORRECT ETIM PRODUCT CLASS 

5.1 Add the product class on import 

Compano recommends adding the ETIM product class of a product on import. Simply add a column to your 
, for instance: 

 
The corresponding import layout should contain the Product Class code (ETIM [version]) data 
field. 
 
Note: For Dutch and Belgium data exchange, please use the Product Class code (ETIM Dynamic) 
version of this field. 

 
Important: The Product Class code (ETIM [version]) data fields can found in the Available fields 
selector, by extending the All Fields category and using CTRL-F  
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5.2 Assign the product class in PIM COS 

Alternatively, you can use the function Manipulate within COS PIM to assign a product class to a set of 
similar products which should all be assigned the same class: 
 

1. At the Product classifications screen, use the Filter and Search options to find a set of similar 
products. 

2.  Select3 all products in the set, either using CTRL-A or the Select All button on the View tab: 

 
3. Next, under Functions, click on Manipulate to assign an ETIM product class: 

 
3 A manual selection can also be made, using SHFT-click and/or CTRL-click. 
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4. In the pop-up window, on the tab Manipulating product, set the Product Class to Grant and fill in an 

ETIM product class code. 

Tip: If you copied the EC-code to your clipboard (see instructions in Appendix A: How to find the 
correct ETIM product class), you can now use CTRL-V to paste the code into the Product Class field: 

 
5. Make sure to click on the class in the drop-down window to properly select the class (!) 
6. Click on Apply to assign the class to all selected products. 

6 Enter common class feature values 

Once a product class has been assigned, the Product Class Features need to be filled out. Depending on the 
status of the classification of the product(s), one of two methods is recommended: 
 
Classification quality status: 

• Fill ETIM features ( ): preferably use the Manipulate method 
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• Complete ETIM features ( ): use the ExcelForImport method 

6.1 Method 1: Manipulate 

For new products with the Fill ETIM features -tatus, you can easily manipulate common class feature values, 

provided you set the Filter to products of a single ETIM class. 
 
To manipulate the values of class features: 
 

1. Through the menu, go to Products > Product Classifications. 
2. Use the Comprehensive Filter to select products of a single ETIM class with classification 
quality status: Fill ETIM features ( ) 

 

Classification tab 

 
• Product class: Select a single ETIM class 

 
Additional tab 

 
• Classification quality: Select the Fill ETIM features status. 

 
3. Optionally, refine your filter results using the Quick Filter of Search options. 

When classifying products, never use the Quick Filter to select products of a single assigned class! 
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4. Select all the products in your set, using CTRL-A, the Select All button, or make a manual 
selection: 

 

 
5. Next, use the Manipulate function: 

 
6. In the pop-up window, go to the Manipulating classification tab: 
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 For each class feature that is common to all products in your set: 

a. Action drop-downs: Select Grant in the drop-down menu. Important: Leave the setting 
for any unique features on No action. 

b. Value fields: Fill out the feature value, either by selecting the (alphanumeric) value from 
the drop-down menu, entering a number, or selecting Yes/No/Unknown. 

7. To save all changes, click on Apply. 

6.2 Method 2: ExcelForImport 

Another method to assign values to common Product Class Features makes use of the ExcelForImport 
option. This method is explained in chapter 8. Update classification. 

7 Enter unique class feature values 

After completing common class features, you will be left with unique class features for each product, which 
also need to be filled out. This can be done using the ExcelForImport option This method is explained in in 
chapter 8. Update classification. 

8 Update classification (ExcelForImport) 

The ExcelForImport-method handles all scenarios for updating classification data: 
 

• Enter common class feature values 

• Enter unique class feature values 

• Change or correct existing classification data 

• Complete classification data 
 
Updating of product classification data can be done through dedicated export layouts for product and 
model classes. These layouts are available on the Product and Product Classification overviews. 
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For convenience sake, a Standaard productclassificatie export in Excel - L03 layout 
has been prepared for COS PIM applications. 

Note: Only (ETIM) classification feature values and Model Class features can be updated this way. (ETIM) 
Product and Model classes need to be assigned to products via Import, Editing or Manipulation. 
 
To update classification data: 
 

1. Through the Menu go to Products > Product Classifications: 

 
2. Use Filter and Search to select a set of products. 

 
Note: The new update method also allows for editing products of multiple, different classes. 

 
3. Go to the Import / Export tab and click on Export products. 
4. In the pop-up window: 

 
5. Use screen layout: Set to No. 
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a. Use screen layout: Set to No. 

b. Export layout: Either select the  Standaard productclassificatie export in Excel - L03 layout, 

or click on the +-icon create a new Classification Export layout. 

c. Prepare for import: Make sure to set this to Yes (!) 
6. Click on the Export button. 

 
The classification data will be exported to an ExcelForImport file, which can be identified by the date and 
time in the file name, for example COS-ExcelForImport-Products-20210607-112956.xlsx. 

The ExcelForImport file can be renamed, however make sure that the filename always starts with 
COS-ExcelForImport, as otherwise the import will fail! 
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8.1 Adding / updating classification data 

The ExcelForImport-file can be used to add or update any classification data. 

How to create an Export Classification layout on-the-fly 
 

I. In the second pop-up window, on the Layout tab, enter a Name for the new layout: 

 
II. Next, on the Properties tab, select the Export type: Include product classes 

 
III. Optional: Next, on the Fields tab, add any other data fields you need in your layout: 

 
IV. Click on Save record to save the layout. 
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The worksheets in the ExcelForImport-file have been protected in such a way that you can only edit 
class features. Please do not remove this protection as the import will fail. 

The following data types can be changed: 

 
• C: The Classified status can be set to Yes if all known and applicable ETIM features have been filled 

out. Also see paragraph 8.2 SET CLASSIFICATION STATUS ON IMPORT. 

• Alphanumeric features: Alphanumeric values can be selected from a drop-down list. Note: The 
drop-down list will contain all ETIM-certified values for the feature: 

 
• Numeric features: Numeric values can be filled out by hand, copy-pasted from another source, or 

can be calculated using standard Excel formulas. 

• Range features: Features where a numeric range must be specified have been split into a minimum 
and maximum value; both need to be filled out: 

 
• Logical features: Correct values for a logical feature are Yes, No or <empty>. An empty value is 

exported in DICO/SALES/INSBOU as Unknown. The logical values can be selected from the drop-
down list: 
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Note: Exporting classification data of multiple classes will result in an Excel file with multiple tabs; one for 
each ETIM class. Select each tab in turn to edit the data of products in that class: 

 

8.2 Set classification status on import 

The Classification status (Yes/No) can be used to indicate whether all known and applicable ETIM features 
have been filled out. See also chapter 9. CLASSIFICATION STATUS for a more detailed explanation. 
 
To set the Classification status  on import, change the value in column C of the ExcelForImport-file:  
 

• Set status to Yes: All known and applicable ETIM features of the product have been filled out 

• Set/leave status to No: Some ETIM-features still need to be filled out, but the correct information is 
currently unavailable. 

 
An alternative method is to 9.2.1 SET CLASSIFICATION STATUS MANUALLY. 

8.3 Importing updated classification data 

Once the update ExcelForImport-file has been saved, the file can be imported into COS: 
 

1. On the Product classification overview, to the Import/Export tab and click on the Import button: 
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2. In the Import dialog, select the COS-ExcelForImport-file that holds your updated data and click on 

Next: 

 
3. In the next dialog window: 

 
a. Reporting level: Select the reporting level for the import report: 

i. None: Do not generate an import report. This will result in the fastest import. 
ii. Full: Generate a full import report, including all changes in all fields. This will result 

in the slowest import as all fields will be checked. 
iii. Only warnings: Generate an import report only listing warnings. This import is 

generally faster than with a Full report. 
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b. Is testrun: Set to Yes to simulate an import; this will only generate an import report listing 
any potential error and/or warnings. No data will be imported! 

c. Selected files: When multiple classes were changed, the import Excel file will contain 
Important: Leave all 

boxes checked to import all the (changed) data of all classes. 
4. Click on Next to start the import and check your e-mail or System > Logs for the Import analysis 

report. For more information on this report, see paragraph 14.2.3 CLASSIFICATION REPORT 

9 Classification status 

Once you have completed assigning or updating your classification data, you might be left with one or more 
features that cannot be filled out, either because: 
 

• The correct ETIM value is missing 

• The class feature is not applicable to your product 

• You do not know the correct feature value 
 
Missing values are best handled by sending a change request to ETIM. Unknown values and not applicable 
features can be communicated to data pools 2BA and InstallData, using the DICO/SALES005 exchange 
format by setting the Classification status to Yes even if not all ETIM features have been filled out. See the 
next paragraphs for a detailed explanation. 

9.1 Missing Value (MV) 

Missing Value only applies to alphanumeric ETIM features where a correct ETIM value is missing for your 
product. 
 

• Alphanumeric value: When the feature does apply to your product, but the correct value is missing, 
select the option Other in the drop-down menu: 

 
Note: A Missing Value code will not be sent to data pools 2BA and InstallData. You can use the ETIM 
Classification Management Tool (CMT) to submit a change request and ask ETIM to add a missing value. 

9.2 Not Applicable (NA) 

Not Applicable means the ETIM Feature does NOT apply to your product and you therefore cannot fill out a 
value: 
 

• Alphanumerical value:  

https://prod.etim-international.com/
https://prod.etim-international.com/


 

24 
 

 
• Numerical or Range value: Leave the field blank: 

 
• Logical value: Choose the option Unknown: 

 

9.2.1 Set classification status manually 

Once you have filled out all ETIM features it is important to set the Classification status of the product Yes. 
Only this way the code NA will be sent to data pools 2BA and InstallData. 
 

The Classification status can be set on import (see paragraph 8.2 SET CLASSIFICATION STATUS ON IMPORT) OR 

MANUALLY: 
 

1. Through the Menu go to Products > Product Classification. 
2. Use Filter and/or Search to find the product. 
3. Under Edit, click on Modify. 
4. In the pop-up window, go to the Product tab: 

 
5. Scroll down to the Status section and set Classified to Yes. 
6. Click on Save. 

 
Alternatively, you can set the Classified status of multiple products using the function Manipulate: 
 

1. Through the Menu go to Products > Product Classification. 
2. Use Filter and/or Search to find the set of products that you need to manipulate. 
3. Use CTRL-A or the Select All button to select all products in the set: 
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4. Under Functions, click on Manipulate. 
5. In the pop-up window, on the Manipulating product tab, set Classified to Grant and select Yes: 

 
6. Click on Save. 

 
Note: Should you make use of ETIM Dynamic and should any changes be made by ETIM to this class, the 
Compano Software will automatically set the Classified status back to No. 
 
Note: You will receive no notification about this status change, however any mutations of ETIM class should 
be apparent from an ETIM mutation report. Compano recommends to generate this report weekly; see 14.3 

ETIM MUTATION REPORT. 

9.3 Unknown (UN) 

Unknown means the ETIM Feature does apply to your product, however you do not know its value (yet) and 
therefore cannot fill out the feature: 
 

• Alphanumerical value:  

 
• Numerical value: Leave the field empty: 
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• Logical value: Choose the option Unknown: 

 

Unknown (UN) is the default code that is sent with empty fields. However, should you export your 
data using the SALES005 exchange standard, then any empty fields of products with the status 
Classified will get the Not Applicable (NA) code. 

10 Special class features 

Some ETIM class features are treated differently; these include Local features and Conditional features. 

10.1 Local features 

With Local Features it is possible to specify country-specific characteristics in ETIM, for example, the Dutch 
quality mark KIWA for drinking water related products. 

 
The old ETIM Feature code indicated that a feature had to start with EF or EFI and then resp. 6 or 5 digits. 
The new Local Features have a different format, namely EF + 2 letters + 4 numbers. The 2 letters are used to 
indicate the country, so for example EFNL0001 stands for the Dutch KIWA label. 
 
Local ETIM features can be filled out just like ordinary ETIM features, and can be exported as of Compano 
version L03. 

10.2 Linked features (UDF) 

With the user-defined fields (UDF) license, you have to option to map UFDs to ETIM class features and values; 
these features are thus linked to the value a UDF and cannot be updated directly. For more information on 
linked features, please see our manual on Mapping User-defined Fields. 

11 Quick corrections: Line Edit 

Alternatively, values of Class Features can be changed directly using the Line Edit function: 
 

1. At the Product Classification screen, with your selection of products ready, under Functions click on 
Line Edit On: 
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2. The screen will reload, changing alphanumeric values to drop-down boxes and changing numerical 

values to on-screen editable fields. Note: Depending on the number of products in your selection, it 
can take a while to reload the screen: 

 
3. Change any alphanumerical or numerical values directly on-screen. Any changes you make are 

immediately written into the Compano database. 
 

Notes: 
a. Click on any numerical value to edit it. 
b. Range values are NOT editable. 
c. Since INSBOU004/SALES005 checkboxes can indicate one of THREE values: Yes, No or 

Unknown Edit function to avoid 
confusion. 

4. Important: Do not forget to click on Line Edit Off to switch line editing off. 

12 Using alternate classification systems 

ETIM is not the only classification system available; besides fixed ETIM versions (ETIM 7, ETIM 6), alternate 
systems include GS1, EZ-base, GPC, Q-model, etc. 

12.1 Static ETIM version (ETIM 10, 9, 8, 7 etc.) 

ETIM is a dynamic classification system with weekly updates to classes, features and values. However, should 
you wish to forego regular updates and concentrate on a static set of classes, features and values, you can do 
so by using any of the fixed ETIM versions. 
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To this end, Compano offers the ETIM 10 (9, 8, 7, etc) static standard, next to ETIM Dynamic. Should you need 
to make use of an even earlier fixed ETIM version, please contact Compano Support, support@compano.com. 

12.1.1 Classification using ETIM 10 (or older) 

By default, the Compano PIM software is set to ETIM Dynamic. To use ETIM 10 (or older) instead: 
 

1. Through the Menu go to Products > Product Classifications: 

 
2. Next, on the Product Classifications screen, at the View tab, select ETIM 104: 

 
3. To classify your products using this system, please follow step 1 to 4 from this manual, substituting 

any instructions for ETIM Dynamic with ETIM 9 instead. 

12.1.2 Copy ETIM classification 

When using multiple ETIM classification systems, you have the option to copy classification from one system 
to the other. 
 
To copy classification: 
 

1. Through the Menu, go to Products > Product classifications. 
2. Switch to the Functions tab and click on Copy classification: 

 
4 Or select another ETIM version. 

mailto:support@compano.com
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3. In the pop-up window: 

 
a. From classification system: Select the classification system from which the data is to be 

copied (SOURCE). 

b. To classification system: Select the classification system to which the data is to be copied 
(TARGET). 

c. Only check run (no update): Set to Yes, if you need to run a simulation of the copying 
process; a report is generated but no actual data is copied. 

4. Click on Execute to start the copying process. 
 
Some things to take note of: 
 

Source Target Action 

Feature value filled Feature value empty Target value overwritten with source 
value 

Feature value filled Feature value filled, but different 
value 

Target value overwritten with source 
value 

Feature value empty Feature value filled Target value not overwritten 

 

• Features that are present in the source-side ETIM system, but not in the target-side ETIM system are 
not copied 

• Features that are present in the target-side ETIM system, but not in the source-side ETIM system are 
left untouched (whether empty or filled) 

12.2 Multi-model classification 

With multi-model classification you can classify your products in multiple, different classification systems, 
such as EZ-base, GPC, Q-model, eCl@ss and EMCS. Multi-model classification is available as an additional 
software module, which will add a classification system selector button to the View tab of your Product 
classification screen: 
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Note: ETIM Dynamic is available as the default classification system. Should you wish to use any other 
classification system, please contact sales@compano.com. 
 
For more information, see the Manual Multi-Model Classification. 

13 ETIM MC (BIM) 

ETIM MC classification process (BIM) is similar to the standard classification process as discussed in this 
manual. For ETIM MC classification follow the steps described in chapters 3 to 7. Any exceptions are 
discussed in the paragraphs below. 
 
Important: Product Models are linked to Product Classes. Therefore, first assign a Product Class to your 
product, before attempting to assign a Product Model. 

13.1 Assign Product Model 

Assigning a Product Model is similar to assigning a Product Class: 
 

1. At the Product Classifications screen, select the product and, under Edit, click on Modify: 

 
2. In the pop-up window, on the tab Model, select the Product Model  

 
3. Selection of the Model will retrieve Product Model Features: 

mailto:sales@compano.com
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4. Either, click on Save to assign the Product Model to the product, or proceed with assigning values to 

the Model Features (see next paragraph). 

13.1.1 Assign to multiple products 

To assign the same Product Model to multiple products: 
 

1. At the Product classifications screen, select all the products you filtered out using SHIFT-click, CTRL-
A or the Select All button: 

 
2. Next, under Functions, click on Manipulate to assign a Product Class: 
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3. In the pop-up window, on the tab Manipulating product: 

 
a. Product class: First, set this option to Grant and enter the ETIM product class of the product 

(EC-code). Note: As the Product Class and Model are linked, this is a mandatory step, even if 
the product has already been assigned a Product Class (!) 

b. Product Model: Next, select the linked Product Model from the drop-down list. 
c. BIM status (optional): Optionally, set the BIM status to Under construction. 

4. Click on Apply. 

13.2 Assign Model Feature values 

To assign values to the Product Model Features: 
 

1. At the Product Classifications screen, select the product and, under Edit, click on Modify: 

 
2. In the pop-up window, on the tab Model, fill in the Product Model Features: 
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3. Next, click on Save. 

13.2.1 Assign to multiple products 

To assign values to Model Features of multiple products: 
 

1. At the Product classifications screen, first set a Filter to select the products of which you need to 
manipulate the Model Features: 

 
a. Classification tab > Product Class: Set this option equal to the ETIM Product Class of the 

product. 
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b. Model tab > Product Model: Set this option equal to the ETIM Product Model of the 

product: 
c. Click on Apply. 

2. Once your product have been filtered, under Functions, click on Manipulate: 

 
3. In the pop-up window, on the tab Manipulating model, set the action to Grant for any features that 

are shared by the products in your selection and fill in the values: 

 
4. Click on Apply. 

13.3 BIM status and export 

The BIM status field is used to facilitate the ETIM MC classification process. The following statuses are 
available: 
 

• None: ETIM MC values will not be exported; this status is useful to indicate that ETIM MC (BIM) 
classification is not ready. 



 

35 
 

• Under construction: ETIM MC values will not be exported; this status is useful to indicate that ETIM 
MC (BIM) classification is in progress. 

• Test: ETIM MC values will be exported when using the SALES005 export format; this format is useful 
for uploading to a data pool (2BA/InstallData). 

• Ready: ETIM MC values will be exported when using the SALES005 export format; this format is 
useful to indicate that ETIM MC (BIM) classification is ready. 

 
To set the BIM status of a product: 
 

1. At the Product Classifications screen, select the product and, under Edit, click on Modify: 

 
2. In the pop-up window, on the tab Product, scroll to BIM status to set the status: 

 
3. Click on Save. 

 
Note: To set the BIM status for multiple products, select multiple product and use the function Manipulate. 

13.4 ETIM MC Viewer 

An alternative way to viewing and editing ETIM MC data, is to use the MC Viewer which is provided by 2BA 
and has been integrated into Compano PIM. 
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13.4.1 Viewing MC-data 

To view Modelling Class data: 
 

1. Through the Menu go to Products > Product Classifications: 

 
2. Switch to the Functions tab, select a product5, and click on MC Viewer button: 

 
3. The MC Viewer will open in a new browser window, where you will be presented with a login dialog. 

Use your personal 2BA account to login: 

 
4. After login, you will have access to the MC Viewer application: 

 
5 Note: Only products with a valid ETIM Model Class (MC######) can be viewed and edited with the MC Viewer. 
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5. Note: MC Class features will be highlighted in the drawing (left column) if you hover your mouse 

over there values (right column): 

 
Important: Should you wish to leave the MC Viewer without editing any data, use the Back button of your 
browser. 

13.4.2 Editing MC-data 

MC-data ca be edited direct within the MC viewer and subsequently be adopted into COS: 
 

1. Within the right column of the MC Viewer, select a class feature and click on the pencil icon: 
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2. In the pop-up window, you will be presented with information on the feature and the value can be 

edited: 

 
3. Once changed, the data can be sent to COS by clicking on the Adopt button: 

 
4. On adopting, the MC Viewer will be closed and you will return to the COS-application. 

13.4.3 Clearing MC-data 

MC-data for a feature can be cleared by using the garbage can icon: 
 

1. Within the right column of the MC Viewer, select a class feature and click on the garbage can icon: 



 

39 
 

 
2. The value for this feature will be cleared: 

 

13.4.4 Measuring progress 

When entering values for class features, you can easily measure your progress by using the Progress button. 
Any features that have not been filled out yet will be highlighted in purple: 
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13.4.5 Zooming in/out 

When you click on any of the features, the MC Viewer will automatically zoom in. Using the buttons in the 
lower righthand corner of the viewer you can reset the zoom level, or zoom in or out manually: 

 

13.4.6 Viewing / downloading / uploading JSON data 

Using the View button, you can view the data in a JSON format: 
 

1. In the MC Viewer, click on the View button: 

 
2. In the pop-up window, the MC-data will be shown in a JSON-format: 
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3. Use the Download button to download the JSON-data. 
4. Use the Upload JSON File button to upload class feature values. Note: Your JSON upload file will 

need to conform to the JSON standard for MC Classes. 
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13.4.7 3D Viewer 

The 3D viewer presents a 3D representation of the Model Class. Class feature values determine the shape and 
dimensions of this representation and any changes in these 

 
 
For instance: 
 
Insert length 12 mm: Insert length 120 mm 

  

13.4.8 Viewer controls 

Rotate 
Click and hold the left mouse button and then drag your mouse to rotate the 3D model. 
 
Grid 
Use the Grid-button to display a grid. The grid will rotate with the model: 
 

 
Axis 
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Use the Axis-button to display a X-, Y-, and Z-axis in the viewer: 

 
Reset orientation 
Use the Reset orientation-button to reset the viewer to its original orientation: 

 
Settings 
Use the Settings-button to change the Object quality of the viewer: 
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14 Quality of data 

Data pools (for instance 2BA or InstallData), wholesalers, fitters, mechanics, or a purchasing consortium all 
demand up-to-date and complete information. To this end, Compano software offers the option to check the 
quality of your data. 
 
Important: Should you classify your products using the ETIM Dynamic system, please remember that this is a 
dynamic system which is updated weekly. Compano will notify you via e-mail in case of any changes in ETIM 
which affect your data. For more information, see paragraph: 14.3 ETIM MUTATION REPORT. 

14.1 Data requirements 2BA and InstallData 

Data requirements for data pools 2BA and InstallData can be found here: 
 
2BA 
https://www.2ba.nl/documentatie/stappenplan/databehoefte > Data requirements (PDF) 
 
InstallData 
https://www.installdata.be/en/documentation/steps-for-data-delivery/data-requirements 
 
These requirements indicate which data is deemed mandatory, highly desirable, desirable or nice-to-have. 

14.2 Quality check classification data 

Compano PIM software offers several options to check your classification data: 

14.2.1 Classification status 

The classification status of your products is indicated with a color code on the Product Classifications screen: 
 

1. Through the Menu go to Products > Product Classifications: 

https://www.2ba.nl/documentatie/stappenplan/databehoefte
https://www.installdata.be/en/documentation/steps-for-data-delivery/data-requirements
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2. On the View tab, check the classification status of your products: 

 
Red: An ETIM product class has not been assigned to the product. 
 

Orange: An ETIM product class has been assigned to the product, however no product class features have 
been filled out. 
 
Yellow: Product class features have been filled out, however the classification is not complete yet. The class 
feature percentage will give an indication as to how much work still needs to be done. 
 

Green: A product with the status Classified. The classification feature percentage is either 100%, which 
means all features have been filled out, ór the product has been manually set to this status; see paragraph: 
9.2.1 Set classification status. 
 
Blue: All mandatory product class features have been filled out. Note: By default, no ETIM features are 
mandatory This status is only possible if you manually set mandatory features. Should you wish to make use 
of mandatory ETIM features, please contact sales@compano.com. 

14.2.2 Export classification data 

To gain insight into the quality of your classification data, Compano PIM offers the option to export a 
classification report, per manufacturer, per ETIM product class, or per manufacturer for all ETIM product 
classes in use: 
 

1. Through the Menu go to Products > Manufacturers: 

 

mailto:sales@compano.com
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2. Next, select a manufacturer and go to the Import/Export tab 
3. Click on the Export classification button: 

 
4. In the pop-up window, set the specifications for the classification export: 

 
a. Send export to: Enter an email address. 

b. Assortment: Select the assortment on which you want to run the export 
c. Product class (optional): Select one product class, or leave empty if you need a 

classification report of all classes in use. 
d. Classification system: Select the classification system for which you need the report. 

Default options are: ETIM Dynamic (EDynamic), ETIM 6, ETIM 7 and OKO. NB: should you use 
the multi-classification module, other classification systems might be available. 

e. Language (optional): Should you use the multi-language module, you will have the option 
to export the classification data in several languages. NB: Without this option, you will only 
be able to export in the default language of your application. 

f. Including canceled products: Set this option to Yes if you need to report on the 
classification including cancelled (archived) products. 

g. Applying source: Set this option to Yes if you need to export (extra) classification features 
which have been added to the standard system. You will be presented with three options: 

i. User: Choose this option if you have added your own custom product class 
features. 

ii. Publicist: Choose this option if you have added custom product class features, but 
need to only export classification data as defined by the original standard. 

iii. Third party: Choose this option if extra product classes or features have been 
added to your classification system by a third party. 

5. Click on Export. The classification export will now be generated. Depending on the number of 
classes that are in use within your data, this can take a while. The export report will be sent as a 
compressed file (ZIP) to the email address that you provided. 

14.2.3 Classification report 

The report resulting from the Export classification function will contain multiple Excel worksheets: 
 

Product Classes worksheet 
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The worksheet named Product Classes will show a summary of your classification data, including Number of 
product classes in use and Expired values: 

 
Important: Check the column Expired values to see if for any classes your data contains expired values. You 
will need to address these classes and correct your data! 
 
Tip: Check any classes with expired values on the ETIM website by comparing the current and previous 
versions of the class: 

 

 
Subsequent worksheets 
All subsequent worksheets each list the classification data of one product class: 
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Optionally check the worksheet for any missing data. 

14.3 ETIM Mutation report 

As mentioned earlier, the ETIM classification system is a dynamic system, which means it will be updated 
weekly. Updates include new product classes as well as changes in Class Features and Values. 
 
To keep up-to-date with changes in the ETIM Dynamic standard, Compano strongly recommends to weekly 
generate an ETIM Mutation Report. 
 

Note: This reports needs to be generated manually. For instructions, see paragraph 14.3.2 MANUALLY 

GENERATING A MUTATION REPORT. 

14.3.1 Set e-mail address 

For PIM Basic and other shared PIM-applications, you will need to set the e-mail address for the ETIM 
mutation report: 
 

1. Through the Menu, go to My Details > Company settings: 

 
2. On the Item Manager tab: 
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a. Send mutation e-mail to: Enter your e-mail address; the ETIM mutation report will be send 
to this address. Note -mail will likely 
be in the Other inbox. 

3. Click on the Close button. 

14.3.2 Manually generating a mutation report 

An ETIM mutation report needs to be manually generated: 
 
To manually generate a mutation report: 
 

1. Through the Menu go to ETIM > Product Classes: 

 
2. Under Functions, click on ICS mail impact analysis: 

 
3. In the pop-up screen, select a past date for Changes since. Note: Always select a Sunday, as ETIM 

changes are being made on a Sunday. 

 
4. De mutation report will be sent to the main user

download the report from the log files. 

14.3.3 Reading a mutation report 

A mutation report is sent as an Excel file, containing multiple worksheets6: 

 
6 The ETIM Mutation report is only available in Dutch. 
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1. Summary (Samenvatting): Overview of all mutations, including all new product classes: 

 

 

1. Summary worksheet 

2. New (Nieuw): An overview of all new product classes. Check this overview to see if any new classes 
are relevant to your products: 

 

 

2. New Product Classes worksheet 

3. Mutations (Mutations): An overview of all mutations pertaining to product classes that are in use in 
your application. This means only changes in product classes that have been assigned to your 
products will be listed. Note: Changes must be read hierarchically, from top to bottom: 

 

3. ETIM mutations for Product Classes in use 

 
Example (see figure 3 above) 

• Row 3: There are changes in class EC000033 Mounting strap 

• Row 4 and 9: Within class EC000033, the class features EF001275 Material qualtiy and 
EF010953 Colour have been changed. 

• Rows 5-8: Class feature EF001275, four class values have been changed: 
 

EV022412 Stainless steel 306 L (1.4404) 
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EV022413 Stainless steel 306 Ti (1.4571) 

EV020090 Stainless steel 316 L (1.4404) 

EV020192 Stainless steel 316 Ti (1.4571) 
 

• Rows 9-16: Class feature EF010953, seven class values have been changed: 
 
 

EV000309 Anthracite 

EV000080 Blue 

EV000083 Brown 

EV000119 Gold 

EV000235 Green 

EV000270 Grey 

EV003609 Purple 
 

Important: To better understand which changes have been, use the ETIM website compare the current and 
previous versions of the class: 

 



 

52 
 

 

14.3.4 Downloading a mutation report 

All users can download mutation reports from the log files : 
 

1. Through the Menu go to System > Logs: 

 
2. Optional  

 
3. Click on the link to download the mutation report (Excel). 
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15 Appendix A: How to find the correct ETIM product class 

There are several methods for finding the correct product class: 
 

• Search for ETIM Product Classes, using the Compano software 

• Lookup the ETIM Product Class and features, using the ETIM International website 

• Check for alternate classes in the ETIM Product Group 

• Check the ETIM Product Class of a similar product of a competitor, using the 2BA website 

Tip: When you find the correct ETIM class, copy the EC-
clipboard, using CTRL-C. 

15.1 Search product classes (Compano) 

To search for ETIM product classes using the Compano software, first open up a new browser tab. The easiest 
way to do this, is to duplicate your current browser tab: 
 

1. -clicking (usually your right mouse button) on the active 
browser tab: 

 
2. Next, select the option Duplicate from the context menu. This will open a new browser tab, while 

keeping you logged in to the Compano application. 
 
In the new browser tab, use the Classification button to look for (ETIM) product classes: 
 

1. Through the menu, go to Classification > Product Classes: 

https://prod.etim-international.com/class
https://2ba.nl/
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2. In the next screen, you will be presented with a list of all ETIM Product Classes: 

 
Note: Depending on the type of application, the overview will show ETIM Dynamic and/or ETIM 8 
and/or ETIM 7 classes. Use the Filter button, to filter out the classification system that you will be 
using: 
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3. Next, type search terms into the Search Box to start looking for the correct class for your product. 
Use keywords from the description of the product, or general terms7 that describe your product, 
such as Boiler, Bolt, Air-conditioning, etc. Note that you might have to try several options before you 
will find the right class: 

 
4. You can always check a class by clicking on its EC-code as this will redirect you to the ETIM 

International website, where you can look up the corresponding class features (see next paragraph). 

15.2 Lookup product class and features (ETIM International) 

Any ETIM product class and its features can be looked up, using the ETIM International website. Click on any 
EC-code in the Compano software, or go to the ETIM International website: 

 
To find the correct class, compare Product Class Features and Feature Values against the technical 
specifications of your product. Also check any optional circulating images (top right) against the appearance 
of your product. 

Tip: When you find the correct ETIM class, copy the EC-code 
clipboard, using CTRL-C. 

Note: Names of product classes, features and values can be translated using the language selector in the 
top-right corner of the ETIM website: 

 
7 For some classes, commonly used alternative or synonymous keywords will also find classes. 

https://prod.etim-international.com/class
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15.3 Check for alternate product classes 

ETIM Product Classes are grouped together with similar classes. If you have trouble finding the correct class, 
try finding any alternatives by checking available classes in the same Product Group: 
 

1. From the Product Classes screen, click on the Product Group code of the class you found but which 
not correct: 

 
2. In the pop-up window, double-click the EG-code and copy (CTRL-C): 

 
3. Through the Menu, go to ETIM > Product Groups: 
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4. Paste (CTRL-V) the EG-code into the Search Box to find the Product Group: 

 
5. From the results, select the product group and under Navigation click on Product Classes. This will 

show a list of all alternative classes in the product group: 

 
6. Check each likely Product Class to see if it better fits your product. 

Tip: When you find the correct ETIM class, copy the EC-
clipboard, using CTRL-C. 
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15.4 Check competitive product (2BA) 

An alternative option for finding the correct Product Class, is to check a similar product of a competitor. The 
product class of the competitive product can be found using the 2BA website: 
 

1. Go to www.2ba.nl and select the page Deelnemers > Fabrikanten and search for a competitor, for 
instance: 

 
 

2. Click on the logo of your competitor and, in the pop-up window, click on Unifeed : 

 
3. Search for the competitive product: 

http://www.2ba.nl/
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4. Select the competitive product by clicking on it: 

 
5. In the left-hand column, click on the product class description of the product: 

 
6. This will take you to the corresponding Product Class on the ETIM website, where you can check if 

this is the correct class for your product. 

Tip: When you find the correct ETIM class, copy the EC-
clipboard, using CTRL-C. 
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