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1 Introduction 

This manual describes how languages in Compano Online Software are used. Topics include: 

 

• User-interface language 

• Translations and fallback of translations 

• Using multiple languages 

• Export of (multiple) languages 

• Translatable description fields 

1.1 Concepts 

COS 

Compano Online Software. 

 

Language codes 

COS uses IETF language tags to represent the main language and culture of a language: 

 

en English main language 

en-US English as used in the United States (culture) 

en-GB English as used in the Great Britain (culture) 

 

Environment language 

Standard language of the environment; this usually is also the database language. 

 

Interface language 

Language setting for a user. Menus, headers, labels, tooltips, system and error messages and any other 

user-interface texts are displayed in this language. 

2 Language settings 

The COS application has several language settings: 

 

• Environment language; this usually is also the database language 

• User-interface language 

• Multilingual text-data fields 

 

Note: These language settings also determines the fallback of translations. This refers to which language 

the application falls back on when no translation has been entered for a language field. See chapter 4 

TRANSLATION FALLBACK SYSTEM (DEFAULT) for more information on the default fallback system. 

 

COS uses IETF language tags to represent the language and culture of a language: 

 

en English main language 

en-US English as used in the United States 

en-GB English as used in the Great Britain 

 

en here is the main language code, according to the ISO 639-1 standard 

US and UK are culture codes, according to the ISO-3166-1 alpha-2 standard 

 

Another example: 

 

https://en.wikipedia.org/wiki/ISO_639-1
https://en.wikipedia.org/wiki/ISO_3166-1_alpha-2
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nl Dutch main language 

fr French main language 

nl-BE Flemish, Dialect of Dutch as used in Belgium 

fr-BE French, as used in Belgium 

 

 

DICO/SALES005 export example 

When you sell items both in the Netherlands and Belgium, which of the Dutch language should do you set? 

Only nl-NL and nl-BE, or is it also necessary to set the for 2BA and Installdata to set nl because the data 

pool cannot handle cultural languages? 

 

Then, on export (for example DICO/SALES005), you should choose only one the available Dutch variants, 

as the standard can only handle one of the nl, fr, and de. Language variants. So, even if you have filled out 

all three variants (nl, nl-NL, nl-BE), you should only choose one of them and it will be exported as the nl -

languages for the industry format. 

2.1 Add languages 

By default a Compano application comes with the following languages: 

 

Application type Default languages Additional languages 

PIM Basis nl None 

PIM International nl, en, de, fr All, incl. culture-specific 

codes 

MDM nl None 

MDM International nl, en, de, fr All, incl. culture-specific 

codes 

 

Additional languages1 can be added manually or by using the Autofill function. 

2.1.1 Auto-fill languages 

The languages Dutch, English, German and French and some of their culture-variants can be added with the 

Autofill function: 

 
1. Through the Menu, go to System > Configuration > Languages. 
2. Under Edit, click on Autofill: 

 
1 Only available with an COS International license. 
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3. The languages nl, de, fr are added in combination with de-DE, en-GB, fr-BE, fr-FR, nl-BE 

and nl-NL. 

2.1.2 Add individual language 

Any (other) language(s) can be added manually: 

 
1. Through the Menu, go to System > Configuration > Languages. 
2. Under Edit, click on +Add: 

 
3. In the pop-up window: 
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a. ISO code: Type the language ISO code; either the single language code (es) or combined 

language-culture code (es-ES). 

b. Description: Type a description for the language. 
c. Use multilingual fields: Set this option to Yes to add translation data fields for this 

language to all translatable fields. 
d. Hide in user interface: Set this option to Yes to hide this language in the user interface. 

4. Click on Save record. 

2.2 Environment language 

As of COS version L03, the default environment (database) language is: en (English), however the database 

language should preferably be the same as the environment languages, so it can be set to a different 

language, for instance nl. 

 

This language is set by Compano at first implementation of the application. Depending upon the type of 

contract/application, the environment can be set to a different language. 

 

To which language the environment (database) is set, can be viewed at Menu > Help > Info: 

 

Figure 1. Environment (database) language is set to 'en-GB English (United Kingdom)' 

The environment language can also be viewed at Menu > System > Configuration > Languages. Look for the 

checkmark under Language environment: 
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Note: The environment language can only be set/changed by Compano Support. 

2.3 User-interface language 

The user interface language determines the language that is used for button texts, labels, headers, system 

messages, error messages and in reports. 

 

Important: The user interface language is also used for non-texts, such as the international list separator, 

character decimal point or thousand separator. Thus, the user interface language should always include 

a culture code, for instance en-UK. 

 

The user-interface language is set for each User at: 

 
1. Through the Menu, go to System > Users: 

 
2. Select the user for which you need to set the user interface language and click on Modify: 
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3. In the pop-up window: 

 
a. Language: Select a user interface language from the drop-down menu. Make sure to select 

a double language code, including culture code. 
4. Click on Save record. 

2.4 Multilingual data fields 

When adding languages to the application, you also have the option to add translation fields for this 

language. For instance, when adding German as a language, fields for German translations of Product 

description, Item description, Series, Type, etc. can be activated. 

 

Note: This option is only available with the International upgrade. 

 

To setup multilingual data fields for a language: 

 
1. Through the Menu, go to System > Configuration: 
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2. In the Overview, click on Languages: 

 
 

3. Click on the Line edit button to activate line editing: 



 

11 

 

 
4. In the column Use multilingual fields, check any languages for which you want to activate translation 

fields, for example: 

 
a. Use multilingual fields: Check the tick box to have this language available as a translation 

field. 
b. Hide in user interface: Check the tick box to have this language available as an optional 

language, but not as a translation field in the user interface. For example: If you  add 
Swedish in this way, you can export data in ETIM Swedish, but in the COS user interface 
there are no translation fields for Swedish visible. 

5. For each checked language translations fields are now added2 to all entities. You can find these 
fields on the Translations tab, for example: under Product: 

 

 
2 Translation fields are only added for 'translatable' fields, such as Brand, Series, Type, Description, but also for user-defined fields 
of the type Text or with textual values (Single and Multiple choice, etc.). 



 

12 

 

2.5 Attachment language 

Attachments can be linked to a language. Thus, for instance, different language-specific manuals can be 

added to a product: 

 

2.6 Document language 

The language in which certain documents such as Offer, Invoice, Quotation, Contract, Order or Work Order 

are generated, can be set at the Company settings: 

 
1. Through the Menu, go to My Details > Company settings: 

 
2. In the pop-up window, go to the tab International: 



 

13 

 

 
a. Language code: Select a language from the drop-down menu. Documents will be 

generated in this language, provided a report template for this language is available. 
3. Click on Close to save the setting. 

 

Important: Report templates in different languages have to be created by the (main) user of the application. 

Note that when the document language is changed, already generated documents are not automatically re-

translated, but have to updated manually. For more information, see the next paragraph. 

2.7 Report template language 

If reports in several languages are needed, a report template for each language has to be created. For each 

a report a language can be set: 

 
1. Through the Menu, go to System > Layouts. 
2. Under Edit, click on Add report template. 
3. In the pop-up window: 

 
a. Language: Select the language for this report. 

4. Click on Save record. 
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Note: A report layout template in different languages is convenient for adding custom texts, such as sales 

conditions, disclaimers, introduction, etc. that are used in every report that is generated based on the 

template. 

 

Important: This language setting has no effect on product or item descriptions, these are retrieved in the 

language which is set at the Company settings, or (overruled by) the language set at the document. 

2.7.1 Updating document translations after reset 

The default language for a document, for instance a Calculation, can be overruled by setting a different 

language for this document only. 

 

Example 

A different language for a particular Calculation can be set manually: 

 
1. Through the Menu, go to Sales > Calculations. 
2. Select the Calculation for which you need to set a different language and under Edit click on Modify. 
3. In the pop-up window: 

 
a. Language: Set a different language for this document (Calculation) only. 

4. Click on Save record. 

 

Important: When changing the language of the application, texts of for instance Orders or Calculations are 

not updated automatically. Thus, for instance when changing the language of a Calculation from English to 

French, translations need to be updated 

 

Example 

Use the Update function to update any texts in the document or entity to the newly applied language: 

 
1. Select the Calculation for which you have changed the language. 
2. Under Functions, click on Update: 
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3. In the pop-up window: 

 
4. In the pop-up window, click on Execute: 

 
5. Check the feedback and click on OK: 
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2.8 Periodic tasks language 

Periodic tasks can also have a language setting. Thus, for instance, a daily BMEcat export can be set to 

exporting data in German. The language can be set at the Periodic tasks settings tab: 

 

 

2.9 Contact language 

When using COS for registering contacts, a preferred contact language can be set for: 

 

• An organization: Set at the Organization tab 

• Each contact person: set at the Contac person tab 
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Note: When setting a language for an Organization, this language setting will be taken over in any 

Documents that are generated for this organization. For example, when selecting a Portuguese organization 

as customer for a quotation, the default language for the quotation document will be set to Portuguese. 

2.10 ETIM and multiple languages 

ETIM International offers the English language (translation) of Classes, Class Features and Values for free. 

Any other languages are managed by local ETIM organisation and are either offered as a paid service or for 

free. 

2.10.1 Shared application 

For shared COS applications, the ETIM Dynamic classification system will be imported weekly. This import 

includes translations for the following languages: English (EN), German (de-DE), Dutch (nl-NL), Flemish (nl-

BE), Belgian French (fr-BE), Suomi/Finnish (fi-FI), Italian (it-IT), Norwegian (no-NO). 

 

Which translations will be imported, depends on your language settings. ETIM languages are offered as a 

culture language, for instance: de-DE, which stands for standard German. When only the main language 

code has been activated in COS, these languages are imported as follows: 

 

• Only main language (de) present in COS: ETIM language is imported as a main language (de) 

• Both main and culture language (de and de-DE) present in COS: ETIM language is only imported as 

a culture language (de-DE) 

2.10.2 Dedicated application 

For a dedicated COS application ETIM Dynamic translation will have to be added manually or by API-call: 

 

Dutch 

The Dutch translations (nl-NL) of ETIM Dynamic can be imported via automated ETIM Client periodic task. 

Access to this API is through a paid-for service of Ketenstandaard.nl. More information can be found on the 

Ketenstandaard website. 

https://ketenstandaard.nl/word-deelnemer/
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Detailed instructions on how to set-up an automated import of the Dutch ETIM Dynamic translations can be 

found in the Manual Periodic Tasks. 

 
Together with Dutch, the following translation will be imported, if the corresponding language has been 

activated in COS:  

 

English (EN), German (de-DE), Flemish (nl-BE), Belgian French (fr-BE), Suomi/Finnish (fi-FI), 

Italian (it-IT), Norwegian (no-NO) 

 

Note: Translations in other languages will each need to be downloaded from the ETIM website of the 

corresponding country. See the next paragraph for instruction on how to import such an ETIM language file. 

2.10.3 Import ETIM language file 

For translations of ETIM in other languages, you will need to download a translation file (usually in the IXF-

format) from the ETIM website of the corresponding country. 

 

Note: Some translation files are freely available, however for some countries you will have to apply for ETIM 

membership to be able to download the required files. Please see the instructions per country below. 

 

French 

You need to apply for membership of ETIM France. 

 

https://www.etim-france.fr/  

 

Spanish 

You need to apply for membership of ETIM Spain. 

 

https://www.etim-spain.es 

 

Portuguese 

You need to apply for membership of ETIM Portugal. 

 

https://www.etimportugal.pt/ 

 

Danish 

You need to apply for membership of ETIM Denmark. 

 

https://help.compano.nl/compano-manuals/manuals-lv.html
https://www.etim-france.fr/
https://www.etim-spain.es/
https://www.etimportugal.pt/


 

19 

 

https://www.veltek.dk/om-veltek/etim-danmark/ 

 

Swedish 

You need to apply for membership of ETIM Sweden. 

 

https://www.etim.se 

 

Polish 

You need to apply for membership of ETIM Poland. 

 

https://etim.org.pl 

2.10.4 Import ETIM [version] language file 

For other ETIM-versions, for instance ETIM 8, separate translation files (IXF-format) are available from the 

Ketenstandaard website. 

 

 

3 Add/edit translations 

Translation fields can be filled out: 

 

• Manually 

• By Import 

• By Update 

3.1 Reference fields 

Important: In COS-applications with a multilingual license, all translatable fields are reference fields. These 

fields ‘contain’ the value of their language-specific counterpart. Which language-specific value is shown in 

the interface, depends on the user-interface language. 

 

Example 

If a user has English set as his user-interface language, all default translatable fields will show the value of 

the English translations of those fields. If the user switches to German as his user-interface language, the 

default fields will show the German translations: 

 

 User-interface language 

Default translatable field English (en) German (de) 

Series Series (en) Series (de) 

Type Type (en) Type (de) 

 

Warning: Thus, to update the value of a translatable field, you have to be careful to update the correct 

language-specific field. Note that by updating the default field, in reality you will be updating the language-

specific field that it currently refers to! 

https://www.veltek.dk/om-veltek/etim-danmark/
https://www.etim.se/
https://etim.org.pl/
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3.2 Add translations manually 

To manually add translations: 

 
1. Through the Menu, go to the entity where you need to add translations, for instance Products: 

 
2. Select a product and, under Edit, click on Modify: 

 
3. In the pop-up window, go to the Translations tab: 
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a. Translatable fields: Edit any of the translatable fields. 
b. Automatic3: By checking this tick box, the translation will automatically fallback according 

to the default COS fallback mechanism, see 4 TRANSLATION FALLBACK SYSTEM (DEFAULT). 
4. Click on Save record. 

3.3 Import translations 

Translations are best filled out using either a regular import or an update import. 

When using the Import function, make sure to only use the language-specific 
translation fields on your import- and screen layouts. Do not use the default 

translatable (reference) fields as this will easily lead to errors. 

More information on importing data can be found in the Manual Universal Import/Export, which is available 

on the Compano Help website. 

3.3.1 Prepare layout(s) 

When preparing layouts, either an Import or Screen layout, the correct language-specific fields can be found 

in the field selector under: 

 

• By category 
o Entity (such as Product, Item) 

▪ Translations 

• Translations [language] 

 
Example 

 
3 Manually setting the Automatic tick box can result in some unexpected behaviour: Checking a tick box next to a filled out field, 
will have that field fallback and possibly show a different language. When unchecking the tick box again, the field will still show 
the fallback text, so if you did not want to change content of the field be careful not to save the record! 

https://help.compano.nl/compano-manuals/manuals-l.html?style=L04
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Suppose you need to translate the fields Series and Type on the entity Product and the language of your 

user interface is English (en). In this case the fields Series and Type refer to Series (en) and Type (en). 

Make sure to use these two language-specific fields on your screen layout: 

 
1. Through the Menu, go to Products > Products. 
2. On the Products overview, go to the View tab and click on Manage screen layouts: 

 
3. Under Edit, click on +Add to create a new screen layout: 

 
4. On the Layout tab, name your layout: 

 
5. Next, on the Fields tab, add the Translation fields. 
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Note: Translation fields can be found under Available fields > By category > Product > Translations > 

Translations English: 

 
Reminder: The default fields Series and Type (crossed-out) cannot be updated as they take 

their content from the language-specific fields of your user interface, in this example their 

English (en) counterparts. 

 
6. Apply the screen layout. 

 

After exporting the product data, the resultant ExcelForImport-file will clearly show the difference between 

the non-editable default data fields (greyed-out) and the editable language-specific data fields (black): 

 

3.3.2 Concatenate texts 

All texts that are imported into a data field on an a single import will be concatenated into a single text. 
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Example 

When you add multiple description texts in different columns in your import file and import all these values 

into the data field Product description during the import, the different texts will be concatenated into a single 

text value. 

 

Please note that the texts are not automatically separated by a space-character; you will need to specify this 

space as a separate import value: 

 

Example Excel import file: 

 

Column A Column B Column C 

This is a [space] Concatenated text. 

 

The resulting value for the Product Description field after import will be: 

 

This is a concatenated text. 

3.3.3 Import values 

To import translation texts: 

 
1. Prepare the import file (either Excel, CSV or Unicode). 
2. Prepare the import layout4. 
3. Use the Import function to import the import file. 

 

More information in importing data can be found in the Manual Universal Import/Export, which is available on 

the Compano Help website. 

3.4 Update translations 

Translations can also be updated (or entered) using the ExcelForImport method. 

 
1. Prepare the screen layout5. 
2. Export the data to an ExcelForImport file. 
3. Edit the ExcelForImport file to add or change any translations. 
4. Use the Import function to import the ExcelForImport file. 

 

More information in updating data can be found in the Manual Universal Import/Export, which is available on 

the Compano Help website. 

4 Translation Fallback System (default) 

When no translation is available for a certain data field, it can fall back on a different language or culture 

language. 

 

Note: The default Translation Fallback System can be replaced by a different system where each fallback 

can be set manually and which thus allows much more control over the fallback of translation. For a detailed 

explanation, see chapter 5 FIELDS FALLBACK SYSTEM. 

 
4 Note: Make sure to use the correct language-specific data fields as explained in chapter 3. 
 
5 Note: Make sure to use the correct language-specific data fields as explained in chapter 3. 

 

https://help.compano.nl/compano-manuals/manuals-l.html?style=L04
https://help.compano.nl/compano-manuals/manuals-l.html?style=L04


 

25 

 

 

The fallback of translations is regulated by two types of settings: 

 

• General fallback setting: Determines whether translations will fall back at all or not. 

• Translation field fallback setting: Determines whether an individual translation field will fallback or 
not. 

 

Important: If the fallback settings and filling out of translations is not properly managed, data fields may 

appear to be filled out, but export an ‘empty’ value. 

4.1 Translation fallback order 

Translation will fall back according to this order: 

 

Culture language 

Main language 

Environment language 

 

Example 

 

nl-BE 

nl 

en 

 

If the nl-BE culture language field is not filled out, the translation will fallback to the nl main language. 

If the main language is also not filled out, the translation will fallback to the en environment language. 

4.2 General fallback setting 

The general fallback of translations can be set at the Company settings: 

 
1. Through the Menu, go to My Details > Company settings: 
2. In the pop-up window: 

 
International tab 
a. Fallback translations: Set this option to Yes for translation to fallback from culture to main 

language to environment language. Set to No to prevent translations from falling back, note 

that no translations might be available for records with empty translation data fields. 
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3. Click on Close. 

4.3 Translation field fallback setting 

The fallback of translations can also be set at for individual translation field with the Automatic checkmark: 

 

Figure 2. By checking the Automatic tickbox, the ‘en -UK’ translation falls back to the 'en' text.  

4.3.1 Manipulating automatic fallback 

For all translatable fields the option Turn automatic on/off has been added to the Manipulation function. This 

way the tick box Automatic next to translatable field can be switched on or off through manipulation: 
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Example 

Series and Type are often language-independent and thus benefit from automatically inheriting their value 

from the default language field. 

4.3.2 Checking automatic fallback 

To easily check if data fields or a record are set to Automatic fallback of translations, a filter can be set, for 

instance: 

 
1. Through the Menu, go to Products > Products and click on Filter: 

 
2. Go to the Translations tab and set the filter for any data field to Automatic: 
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Figure 3. Filter all records where the Commercial description is set to Automatic. 

3. Click on Apply. 

4.4 Fallback in JSON feeds 

The fallback of translations in feed is dependent on the central fallback setting at My Details > Compano 

Settings > tab International: 

 
When set to Yes, translatable fields in the feed will follow the standard fallback scheme; when set to No, 

translatable fields in the feed will not fallback. 

 

More information on exporting languages in JSON, can be found in the Manual JSON Feeds, which is 

available on the Compano Help website. 

5 Fields Fallback System 

COS already contained a default Translations Fallback System where fallback of language-specific text data 

fields was handled according to a hard-coded setup. Thus, for instance, nl-BE (Flemish) could fall back on 

the main language nl, and ultimately to the system-wide standard language (usually en). However, this 

system did not provide for desired fallback of, for example en-US to en-GB, or set a fallback of Short 

Description (product) to Long Description (product), or even Description (Product group). 

 

The Fields Fallback System now provides for setting multiple, consecutive fallbacks to any string-type data 

field. 

 

https://help.compano.nl/compano-manuals/manuals-l.html?style=L04
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This system is much more flexible and will also allow for such setups as: 

 

• Only filling out product descriptions and let fallback handle item descriptions, as in most cases both 
descriptions are exactly the same. 

• Set a fallback for Commercial descriptions to a general Product group description and only deviate 
for products that need an additional or different commercial text. 

 

A Fields Fallback System has been added to the application, which can be switched on by disabling the 

default fallback system. A new Configuration overview allows for setting detailed fallbacks for the text data 

fields of the entities the entities Product, Product group, Item and Item group. 

 

Data fields for fallback can be added at will for any of the above mentioned entities and can also be archived 

or removed. The configuration is cached for performance reasons. 

5.1 User rights 

The overview Fields Fallback (Configuration) is under a new user right; therefore, that right must be set for  

any users that need access to this view. If this right is not set, only the administrator will have access to this 

overview. 

5.2 Restrictions 

Some restriction apply to the new Fields Fallback system: 

 

• Texts are truncated to the maximum length of the target field; for instance, Product 
descriptions (max 256 characters) will be truncated to 70 characters when a fallback is set to 
the Product short description field. 

• The fallback of Deep links is hard-coded: First the deep link of the item is determined, if this 
is empty then the deep link will fall back to the deep link of the product. 

• Fields fallback is not recursive. Thus, a data field will only fall back to the value of the data 
field(s) to which it is set. If this data field itself is empty and falls back to another data field, 
this second fall back will not activate. 

• When changing any fallback settings, the Activate function must be used, before any 
changes will become active, as the fallback definition is cached to optimize performance. 

5.3 Changes 

The following fields had a hard-coded fallback to Purchase Item, however this fallback has been removed 

in favour of the new Fields Fallback system: 

 

• Commercial description (item) 

• Technical description (item) 

 

In addition, for a number of language-based fields, the following Manipulation options have been removed: 

 

• From purchase item 

• From product 

• From preferred item 

• From description 1 and 2 
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5.4 Configuration 

Before the Fields Fallback system can be used, the following actions need to be performed: 

 

• Deactivate the default Translations Fallback System 

• Add data fields for fallback 

5.4.1 Deactivate Fields fallback system 

By default an International COS application makes use of a Translation fallback system. However, to use 

the alternative Fields Fallback system, Translation fallback first needs to be disabled: 

 
1. Through the Menu, go to My details > Compano settings: 

 
2. In the pop-window, on the International tab: 
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a. Fallback translations: Set this option to: No 

3. Close the window. 

Important: The Fields fallback system can also be used to set fallback of translations, 
however unlike the default Translation fallback system, with Field Fallback all 

translation fallbacks have to be set manually. 

5.4.2 Add data fields for fallback 

Next, the data fields for which you want to set the fallback need to be added: 

 
1. Through the Menu, go to System > Configuration: 

 
2. On the Configuration overview, click on the Fields Fallback link: 
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3. On the next screen, under Edit, add the fields of one or more entities for which you need to set a 

fallback: 

 
4. For example, for Item the following data fields will become available for fallback: 



 

33 

 

 
5. Under Functions, click on Activate to activate the new fallback settings for these fields. 

 

For each of the added data fields, the fallback can now be set; see the next paragraph. 

5.5 Set fallback of data fields 

To set the fallback of an individual data field: 

 
1. Through the Menu, go to System > Configuration: 

 
2. On the Configuration overview, click on the Fields Fallback link: 
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3. On the next screen, select the data field for which you need to set a fallback, for example (Item) 

Short Description/Nederlands (België) and click on Modify: 

 
4. In the pop-up window: 

 
a. 1st Fallback field: Set the first data field to which the data field should fallback when empty. 
b. 2nd Fallback field: Set the second data field to which the data field should fallback when it 

and the 1st fallback field are empty. 
c. 3rd Fallback field: Set the third data field to which the data field should fallback when it and 

the 1st and 2nd fallback field are empty. 
d. 4th Fallback field: Set the fourth data field to which the data field should fallback when it and 

the 1st , 2nd and 3rd fallback field are empty. 
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5. Save the record. 
6. Important: Use the Activate function to activate this particular fallback6): 

 

5.5.1 Finding data fields 

The fallback can be set to a large number of fields. To find a specific field: 

 

• Use the Filter to select the data fields of a certain entity: 

 
6 Make sure to use Activate any time you make a change to the fallback settings! 
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• The filter can be combined with the Search option, for instance: short description: 

 

5.5.2 Finding fallback options 

To find the correct data field for fallback, you can try to: 

• Type (part of) a word from that data field description, for instance for the 1st Fallback field: short 
description to find all the Short description options on the entity Product: 

 
• Type a language code, for example dk-DK: 
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5.6 Export of fallback settings 

The Fields Fallback settings can become quite complex. To facilitate understanding of your current fallback 

settings, these can be exported to an Excel file: 

 
1. Through the Menu, navigate to System > Configuration > Fields Fallback. 
2. Optionally set a filter on the Entity for which you want to perform an Export. 
3. Select all (of part of) the fields on the Overview and, on the Import/Export tab, click Export fields 

fallback: 

 
4. In the pop-up window: 
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a. Use screen layout: Set this to Yes. 

5. Click on Export. 
6. The resulting Excel file contains a comprehensive overview of all fallback settings: 

 

6 Multilingual exports 

6.1 Industry standard exports 

When exporting in the DICO/SALES005 or BMEcat 4.2/5.0 formats, you can select which languages to 

export: 
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6.1.1 Attachment exports (DICO/SALES005) 

Care should be taken when exporting attachments which have been linked to a specific language. 

 

When exporting in the DICO/SALES format, one or more languages and/or cultures can be selected: 

 

• Main language selected: Only attachments which are linked to the main language will be exported. 

• Culture variant selected: Both attachments linked to the culture variant (nl-BE) and attachments 

linked to the main language (nl) will be exported (!) 

• Note: An attachment that is not linked to any language will always be exported. 

 

Example 

 

 Attachment published with DICO/SALES005? 

Selected language option 

in DICO export dialog 

Attachments with 

only main language 

code 

 

 

(nl) 

Attachments with 

main language and 

language variant 

code 

 

(nl-BE) 

Attachments without 

a language code 

 

 

(-) 

Main language (nl) Yes No Yes 

Culture variant (nl-BE) Yes Yes Yes 

 

Important: If only one language is selected in the export dialog and the attachment is not linked to any 

language, this attachment will be published with the main language code of the selected language (!). 

6.2 Data pool exports 

When exporting to data pool 2BA or InstallData in the DICO/SALES format, you can also select which 

languages to export. However, make sure to select only one culture per language as culture languages are 
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published with the main language code. For instance, selecting nl-BE as the culture language will export 

data to 2BA with the main language code nl. Currently7, data pools 2BA and InstallData cannot handle 

culture languages. 

 

More information on exporting languages to data pools 2BA and InstallData, can be found in the Manual 

Publishing on Datapools, which is available on the Compano Help website. 

7 Appendix A: Translatable description fields 

For Product and Item, several description fields are available: 

 

Product Item 

Brand  

Series  

Type  

Description Description 

Short description Short description 

Commercial description Commercial description 

Technical description Technical description 

 Brief description 1 

 Brief description 2 

7.1 Short and long description 

Short description 

• Max. 70 characters 

• Exported in all exchange formats 

 

Long description 

• Max. 256 characters 

• Exported in formats: INSBOU004, DICO/SALES005, BMEcat 2005 5.0 

7.2 Commercial and Technical description 

Commercial description 

Marketing text, unlimited number of characters, except for export formats 

Exported in formats: INSBOU004, DICO/SALES005, BMEcat 2005 4.2 and 5.0 

 

Important: Within the Compano application, the number of characters in the Commercial Description field is 

unlimited. However, for exports in the DICO format, the maximum the number of exported characters will be 

truncated to 1000 characters. This is because the DICO standard (insbou004/sales005) stipulates that the 

field may only be 1000 chars long. 

 

Any exports in JSON or XML format will contain all characters of the Commercial Description field. Thus, 

the full commercial text can be used for your own product website, webshop or print catalog. 

 

Technical description 

• Technical text, unlimited number of characters, except for export formats 

• Exported in formats: INSBOU004, DICO/SALES005, BMEcat 2005 4.2 and 5.0 

 
7 19-9-2022 

https://help.compano.nl/compano-manuals/manuals-l.html?style=L04
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• Not imported by data pool 2BA/InstallData. 

• Can be used in data feeds, for example for website / webshop. 

7.3 Brief description 

Brief Description 1 

• Max. 40 characters 

 

Brief Description 2 

• Max. 40 characters 

• Only used for exports in Arge Neue Medien format. 

• Can be used as extra description fields in data feeds. 
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